Users from old forum should register again, the old credentials no longer are valid

2.0.69.0 High CPU/Memory bug

Report bugs and errors to the digiCamControl development team.
Post Reply
Wolsley
Posts: 16
Joined: Tue Oct 06, 2015 6:09 pm

2.0.69.0 High CPU/Memory bug

Post by Wolsley » Sat Aug 26, 2017 7:43 pm

I have notice a serious Memory/CPU bug in version 2.0.69.0 I have had the program hang several times. I use a NIKON D5300 shooting RAW at 600x4000 so the photos are 24Mpixel. I shoot use the Astro module. This morning I decided to do some testing so I called up DCC which showed me last night's photos without using the Astro module. I also ran a program I wrote which shows me graphs of the total virtual memory usage and the CPU usage for any application that is running. Please see the attached jpg for an annotated screen capture of my program while monitoring DCC.
It looks, to me, that there is something strange that happens the first time you double-click on an image to see it full-screen. The requested image appears immediately within 1/10th second exactly as expected. For the next several seconds DCC consumes up to 1Gb of virtual memory while using 100% CPU. It takes close to 10 seconds for this high CPU usage to end. If I close the full-screen window I now notice that if I use the Left/Right buttons to scroll thru the images I once again see the ~10 second high CPU/Memory usage occur for every image I scroll thru. If, instead, I use the scrollbar to scroll thru the images the high CPU/Memory bug does not occur. Regardless of whether I use the Left/Right arrows or the scrollbar the images appear quickly so this bug is very much a background processing issue. I believe that this occasionally causes DCC to hang/crash and may also interfere with my Astronomy Software.

Peter
Attachments
DCCBug.jpg
V2.0.69.0 Memory/CPU bug
DCCBug.jpg (130.52 KiB) Viewed 289 times

2.0.69.0 High CPU/Memory bug

Advertisment
 

Wolsley
Posts: 16
Joined: Tue Oct 06, 2015 6:09 pm

Re: 2.0.69.0 High CPU/Memory bug

Post by Wolsley » Sun Aug 27, 2017 9:10 pm

I repeated this testing and all of the versions I tested have the same high CPU/Memory bug
V2.0.0.0
V2.0.49.0
V2.0.58.0
V2.0.69.0
The frustrating part is that the program responds very well. Screen pop-up quickly and refresh quickly. In the background my computer is struggling with high CPU usage and Memory allocation that lasts for a very long time. If you double-click an image to view it full screen and then use the scroll buttons to scroll thru the images you could have your computer stay in a high CPU/Memory state for over a minute. I worry this will seriously interfere with other applications on my computer.

Peter
Attachments
DCCBug1.jpg
Error message if DCC closed during high CPU/Mem state
DCCBug1.jpg (23.89 KiB) Viewed 285 times

Duka Istvan
Posts: 522
Joined: Sat Oct 03, 2015 7:57 pm

Re: 2.0.69.0 High CPU/Memory bug

Post by Duka Istvan » Mon Aug 28, 2017 9:46 am

I try to reproduce this issue but with no luck yet....
Do you use raw or jpg images ?

Wolsley
Posts: 16
Joined: Tue Oct 06, 2015 6:09 pm

Re: 2.0.69.0 High CPU/Memory bug

Post by Wolsley » Mon Aug 28, 2017 5:20 pm

Duka,
Always Nikon RAW (NEF). If you wish I can put 5 or 10 up on dropbox for you to work with. I will do further testing using JPGs.

Peter

Wolsley
Posts: 16
Joined: Tue Oct 06, 2015 6:09 pm

Re: 2.0.69.0 High CPU/Memory bug

Post by Wolsley » Mon Aug 28, 2017 5:39 pm

I just did a quick test with a series of 2990x2000 jpgs. No issues found. My Nikon RAW files are 6000x4000 which are 24Mpixel. When the high CPU/Memory event starts I can see a ramping up of the virtual memory usage from 277Mb to 994Mb over the course of 4 or 5 seconds. Once the 994Mb virtual memory threshold is reached this memory is held for a further 15 seconds and then drops back to it's 277Mb level.

Wolsley
Posts: 16
Joined: Tue Oct 06, 2015 6:09 pm

Re: 2.0.69.0 High CPU/Memory bug

Post by Wolsley » Mon Aug 28, 2017 5:50 pm

Duka,
Here is a link to 15 Nikon 24Mb NEF files. They are FLATs (exposures of a blank surface) required for astrophotography. I have tested them and they also show this high CPU/Memory bug.

Peter

https://www.dropbox.com/sh/67b0pie8lki6 ... qle8a?dl=0

Wolsley
Posts: 16
Joined: Tue Oct 06, 2015 6:09 pm

Re: 2.0.69.0 High CPU/Memory bug

Post by Wolsley » Mon Aug 28, 2017 6:15 pm

Duka,
Please wait until 1PM to fetch these photos. Dropbox takes a while to synchronize the folder.

Peter


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest