Users from old forum should register again, the old credentials no longer are valid

D7000/D5100 liveview not active (Win XP)

Report bugs and errors to the digiCamControl development team.
Post Reply
drathomas
Posts: 8
Joined: Sat Jul 15, 2017 11:37 pm

D7000/D5100 liveview not active (Win XP)

Post by drathomas » Sun Jul 16, 2017 8:22 pm

I installed the latest stable version (2.0.0.0) on a XP laptop. The software works fine (taking images, displaying shutter speeds etc.) but liveview is inactive (icon greyed out). As this is an issue with both a D7000 and a D5100 I guess it might be a problem with the XP os. Any information on this issue?
Thanks in advance!

D7000/D5100 liveview not active (Win XP)

Advertisment
 

drathomas
Posts: 8
Joined: Sat Jul 15, 2017 11:37 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by drathomas » Fri Jul 21, 2017 1:03 am

I installed v2.0.49 - in this version liveview works as expected both with D7000/D5100.
Great!

Duka Istvan
Posts: 524
Joined: Sat Oct 03, 2015 7:57 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by Duka Istvan » Fri Jul 21, 2017 9:20 am

Thanks for the feedback

drathomas
Posts: 8
Joined: Sat Jul 15, 2017 11:37 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by drathomas » Fri Jul 21, 2017 11:35 pm

Sorry, that was a wrong information: v2.0.49 works on Win7, but not on XP.
As far as I understand v2.0.49 or higher requires .Net framework > 4.5 and this in turn requires Win7 or higher. v2.0.0 obviously still works with .Net 4.5 (available on Win XP SP3), but here liveview does not work.
I tried to follow this thread
viewtopic.php?f=3&t=726&p=1831&hilit=li ... +msi#p1831
but running the regwia.bat file does not create an INF file that can be used to update the driver.
Any idea to have liveview running under v2.0.0 ?

Duka Istvan
Posts: 524
Joined: Sat Oct 03, 2015 7:57 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by Duka Istvan » Sun Jul 23, 2017 11:10 pm

The issue is the cameras are recognized as WIA devices not MTP device. You should install Windows Media Player (i don't know where you will get it since Windows Xp not longer supported by MS) and you should plug the camera in a another usb port

drathomas
Posts: 8
Joined: Sat Jul 15, 2017 11:37 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by drathomas » Mon Jul 24, 2017 12:13 am

Thanks for the information,
Windows Media Player is installed and I have tried all 4 USB ports on my laptop but I still do get no liveview. Anything else I have to pay attention to?

drathomas
Posts: 8
Joined: Sat Jul 15, 2017 11:37 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by drathomas » Sat Jul 29, 2017 12:47 am

Istvan, is there anything else that I can try to activate liveview? As I said Windows Media Player is installed and I have tested all USB ports.
You noted that the camera has to be recognized as an MTP device. I found
https://www.microsoft.com/en-in/downloa ... x?id=19153
Is this something that could help?
Thanks in advance!

Duka Istvan
Posts: 524
Joined: Sat Oct 03, 2015 7:57 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by Duka Istvan » Sat Jul 29, 2017 11:39 am

Please send your log file (Menu=>Help=>Send log file)

drathomas
Posts: 8
Joined: Sat Jul 15, 2017 11:37 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by drathomas » Sun Jul 30, 2017 12:11 am

Just sent the log file - hope it helps to find the problem. Thanks!

drathomas
Posts: 8
Joined: Sat Jul 15, 2017 11:37 pm

Re: D7000/D5100 liveview not active (Win XP)

Post by drathomas » Tue Aug 08, 2017 12:19 am

Any findings or news about this problem?

Regards, Axel


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest