Errors compiling CameraControl.sln

Post Reply
Mark_Wilson
Posts: 3
Joined: Thu Aug 11, 2016 3:17 am

Errors compiling CameraControl.sln

Post by Mark_Wilson » Thu Aug 11, 2016 10:58 pm

I've installed Windows 10 and Visual Studio 2013 Community with all the default settings. I then installed the .NET 4.6 targeting packs. Next I downloaded the source files in the .ZIP from GitHub (current as of August 11, 2016).

Finally I tried to compile CameraColtrol.sln and I'm faced with over 60 errors. I assume that I missed some important component that I need to add to this configuration.

I'm not a C# or a .NET programmer (yet) so this might be something really obvious but its beyond me for the time being.

I've attached the error list as a file to this post. Any idea what I need to do to get past this problem?

Thanks.
Attachments
errors.txt
(15.44 KiB) Downloaded 149 times

Errors compiling CameraControl.sln

Advertisment
 

BStrauss3
Posts: 33
Joined: Sun Jun 12, 2016 11:12 pm

Re: Errors compiling CameraControl.sln

Post by BStrauss3 » Sun Aug 14, 2016 5:08 pm

I may have introduced a code construct from a later version of C#

Code: Select all

public static bool IsVerbose { get; set; } = false;
I use VS2015 Community edition (the free version).

However I didn't touch App.xaml.cs - this too is a modern construct

Code: Select all

Current?.Shutdown();

Can you upgrade to VS2015? Baring that you will have to remote the "= false" from the 1st line and replace the second by the if test:

Code: Select all

if (Current != null)
	Shutdown();
(I don't have access to my machine from here, so the above is from memory)

Mark_Wilson
Posts: 3
Joined: Thu Aug 11, 2016 3:17 am

Re: Errors compiling CameraControl.sln

Post by Mark_Wilson » Mon Aug 15, 2016 3:55 am

Thanks. I upgraded to Visual Studio 2015 Community Edition. When I compiled I got 546 errors but on further inspection I found I was looking at Build + Intellisense errors combined. The build errors were only about 6. The most serious being this:

Error CS0246 The type or namespace name 'Canon' could not be found (are you missing a using directive or an assembly reference?) CameraControlCmd C:\C-Test\digiCamControl-master\CameraControlCmd\Program.cs 471

That was caused by this line:
catch (Canon.Eos.Framework.EosException exception)


The other was a Setup error which I'm not concerned about at the moment.

My fix for the first error was to just comment out that segment as my camera isn't a Canon model.

The program builds and starts so I think I'm good to go and start tinkering with the code.

Again, Thanks.

Duka Istvan
Posts: 684
Joined: Sat Oct 03, 2015 7:57 pm

Re: Errors compiling CameraControl.sln

Post by Duka Istvan » Mon Aug 15, 2016 11:00 am

Can you check the source again? Now should compile fine.

lokatz
Posts: 9
Joined: Fri Aug 19, 2016 9:50 am

Re: Errors compiling CameraControl.sln

Post by lokatz » Fri Aug 19, 2016 10:04 am

Hi Duka,

I've had similar issues as of last week but just re-tested it: everything compiles fine now in VisualStudio 2015. Thanks for your help.

Best,
Lothar

Post Reply