Unable to Stop Recording Movie

Report bugs and errors to the digiCamControl development team.
Post Reply
digicamcontroller
Posts: 2
Joined: Thu Sep 06, 2018 1:08 pm

Unable to Stop Recording Movie

Post by digicamcontroller » Thu Sep 06, 2018 1:21 pm

Dear team,

Thank you for the great product that you have developed here. I am currently using the standalone library, CameraControl.Devices -Version 2.0.73-beta and I am able to start recording. However, as soon as I try to stop recording a movie, I will be prompted with an error:
"Device Busy.Failed to set property integer data: propertyId 1296, data 0"

Would you be able to advise as to what I am doing wrong? On the Canon EOS 600D, I am able to start recording and stop recording movies without problem using the same code. It's only when I switch to the Canon EOS 6D that I encounter this error.

Looking forward to hearing from you soon. :)

Unable to Stop Recording Movie

Advertisment
 

digicamcontroller
Posts: 2
Joined: Thu Sep 06, 2018 1:08 pm

Re: Unable to Stop Recording Movie

Post by digicamcontroller » Tue Sep 11, 2018 9:26 am

Hello there! Sorry but just wondering if anyone else encountered this problem while testing?

fran@servifot.com
Posts: 10
Joined: Fri Jun 22, 2018 3:44 pm

Re: Unable to Stop Recording Movie

Post by fran@servifot.com » Mon Oct 08, 2018 1:42 pm

I have the same problem. Did you find any solution?
With Canon EOS 1300D

fran@servifot.com
Posts: 10
Joined: Fri Jun 22, 2018 3:44 pm

Re: Unable to Stop Recording Movie

Post by fran@servifot.com » Wed Oct 10, 2018 10:31 am

Hi again.

I finally modified the method that is used for canon recording.
In Canon.Eos.Framework.EosCamera.cs the method public void StartRecord()
Change the body
public void StartRecord()
{
LiveViewqueue.Enqueue(() =>
{
StopLiveView();
SavePicturesToCamera();
this.SendCommand(Edsdk.CameraCommand_MovieSelectSwON);
StartLiveView();
this.SendCommand(Edsdk.CameraCommand_DoEvfAf, 0);
SetPropertyIntegerData(Edsdk.PropID_Record, (long)4);
});
}

by

public void StartRecord()
{
SavePicturesToCamera();
this.SendCommand(Edsdk.CameraCommand_DoEvfAf, 0);
SetPropertyIntegerData(Edsdk.PropID_Record, (long)4);
}

And the public void StopRecord() is changed to:

public void StopRecord()
{
SetPropertyIntegerData(Edsdk.PropID_Record, (long)0);
}

That worked for me :)

command&control
Posts: 1
Joined: Wed Oct 17, 2018 11:08 am

Re: Unable to Stop Recording Movie

Post by command&control » Wed Oct 17, 2018 11:15 am

fran@servifot.com wrote:
Wed Oct 10, 2018 10:31 am
Hi again.

I finally modified the method that is used for canon recording.
In Canon.Eos.Framework.EosCamera.cs the method public void StartRecord()
Change the body
public void StartRecord()
{
LiveViewqueue.Enqueue(() =>
{
StopLiveView();
SavePicturesToCamera();
this.SendCommand(Edsdk.CameraCommand_MovieSelectSwON);
StartLiveView();
this.SendCommand(Edsdk.CameraCommand_DoEvfAf, 0);
SetPropertyIntegerData(Edsdk.PropID_Record, (long)4);
});
}

by

public void StartRecord()
{
SavePicturesToCamera();
this.SendCommand(Edsdk.CameraCommand_DoEvfAf, 0);
SetPropertyIntegerData(Edsdk.PropID_Record, (long)4);
}

And the public void StopRecord() is changed to:

public void StopRecord()
{
SetPropertyIntegerData(Edsdk.PropID_Record, (long)0);
}

That worked for me :)
Doesn't work for me. :( I tried with the Canon EOS 200D. Unable to stop recording. Thank you for sharing though, fran@servifot.com.

fran@servifot.com
Posts: 10
Joined: Fri Jun 22, 2018 3:44 pm

Re: Unable to Stop Recording Movie

Post by fran@servifot.com » Thu Oct 18, 2018 2:27 pm

command&control wrote:
Wed Oct 17, 2018 11:15 am

Doesn't work for me. :( I tried with the Canon EOS 200D. Unable to stop recording. Thank you for sharing though, fran@servifot.com.
¿Can you share your Methods to see what's happening? I'd have a look if you share them.

eeyteo
Posts: 1
Joined: Mon May 20, 2019 5:00 pm

Re: Unable to Stop Recording Movie

Post by eeyteo » Mon May 20, 2019 5:03 pm

I had the same problem with my canon ESO550D, I solved by setting the wheel selector, on the camera, on "Auto": now it starts and stops recording properly. In my case, the 1296 problem presented itself only when the selector was on "Video" mode.


Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest