Photo transfer speed 0 Mb/s (jpeg file size is 0)

Report bugs and errors to the digiCamControl development team.
Post Reply
Bbb
Posts: 2
Joined: Fri Feb 08, 2019 7:40 pm

Photo transfer speed 0 Mb/s (jpeg file size is 0)

Post by Bbb » Fri Feb 08, 2019 8:08 pm

After a successful photo capture by the camera digiCamControl pops a message "Photo transfer done Transfer Time: 2.062 Speed: 0 Mb/s".
The created jpeg file on PC has size of 0 bytes.
The file in the camera is fine.

Log excerpt:
2019-02-08 18:08:25,314 [7]DEBUG DCC [(null)] - File nameDSC_0000.JPG
2019-02-08 18:08:25,326 [7]DEBUG DCC [(null)] - Photo transfer begin.
2019-02-08 18:08:27,390 [7]DEBUG DCC [(null)] - Transfer time : 2.062 Speed :0 Mb/s
2019-02-08 18:08:27,468 [7]DEBUG DCC [(null)] - Window command received :Select_Image
2019-02-08 18:08:27,471 [7]DEBUG DCC [(null)] - Photo transfer done.
2019-02-08 18:08:27,540 [6]DEBUG DCC [(null)] - Unable load thumbnail: C:\Users\AAATom\Pictures\digiCamControl\Session1\DSC_0001.jpg
... (continues with a bunch of exception messages that seem related to bad jpeg)
Full log file attached.

I am on Windows 10 Pro, DigiCamControl v2.1.0, camera Nikon D3300, Windows camera driver version 10.0.17134.1.
If it matters, it is a virtual machine on VMware Workstation 11 - I also have Windows 7 VM on which it works fine (with a different camera driver version of course).

It does look like a camera driver issue - has anyone had a problem like this?
Attachments
app [bad jpeg transfer p1].log
(9.19 KiB) Downloaded 5 times

Photo transfer speed 0 Mb/s (jpeg file size is 0)

Advertisment
 

dman
Posts: 1
Joined: Sun Feb 17, 2019 5:40 pm

Re: Photo transfer speed 0 Mb/s (jpeg file size is 0)

Post by dman » Sun Feb 17, 2019 5:44 pm

I have the same problem with the same camera (nikon d3300). I can reliably duplicate the problem when DigiCamControl is told to save the images to both the camera and the computer. When DigiCamControl is told to save the images to the computer ONLY, the problem seems to disappear. I assume the images stay on the camera's memory card (while DigiCamControl is in the "save images to computer only" mode, but I have not yet confirmed my theory.

Bbb
Posts: 2
Joined: Fri Feb 08, 2019 7:40 pm

Re: Photo transfer speed 0 Mb/s (jpeg file size is 0)

Post by Bbb » Mon Feb 18, 2019 6:21 pm

I just looked at this again and on a hunch changed VM setting for the USB controller - changed "USB compatibility" from USB 3.0 to USB 2.0 - and it started working normally. :o :D
The physical USB port where the camera is connected is USB 3.0 so I did not consider it relevant before.

So it does look like a USB driver issue rather than camera driver issue.

That is, at least in my case. For me, saving to computer only and saving to camera & computer setting had the same result (no images saved to computer).
Obviously, reporting this kind of errors needs better handling in digiCamControl.

speedy
Posts: 1
Joined: Sun Mar 17, 2019 11:49 pm

Re: Photo transfer speed 0 Mb/s (jpeg file size is 0)

Post by speedy » Sun Mar 17, 2019 11:59 pm

got the same problem with nikon D80. Picture can only be saved to camera sd card, not to both pc and camera.
once picture is saved to camera sd card, digicam control software and pc explorer do not have access to camera sd card any more. Device busy! MTP Device busy familiar bug appears. On latest version 2.1.1.0. Simply the usb needs to be disconnected and reconnected (or camera switched off/on) for software to continue working.
Why would digicam control lock usb traffic from camera>pc ?
just uploaded log file to developers so you can take a look.
Basically you keep adding new features to the software and never fix old glitches like MTP device busy error and locking up usb port.


Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests