Overlay bug (depends on aspect ratio and manual mode)

Report bugs and errors to the digiCamControl development team.
User avatar
Kalais
Posts: 1
Joined: Wed Feb 17, 2021 3:50 pm

Overlay bug (depends on aspect ratio and manual mode)

Post by Kalais » Wed Feb 17, 2021 4:12 pm

Hello,
first of all, great software! Thanks for the awesome work!

I would like to report bug with overlay option that I found others had too. I read those 2 topics and figured out what is causing the problem:
- viewtopic.php?t=3070
- viewtopic.php?t=3290

In my case camera is Canon EOS 80D, but as you can check in other posts it doesn't really matters since other Canons and Nikon have same issue.

So in full automatic mode, photo mode (not video) everything works fine. The overlayed last captured frame is not stretched.

The problem occurs when you go to M mode (full manual). The overlayed image getting stretched. Here is an example:

Live view with correct proportions:
Image

Transparency: 40.
Image

Transparency: 100. Clearly you can see distortion.
Image

The only solution for this to work is to change aspect ratio of photos made to 3:2. In this apect ratio there is no distortion on overlay image, even in full manual mode.

The bug appears in 16:9, 4:3 and any other aspect ratio in M mode.

In automatic mode you can choose any aspect ratio and there is no bug with stretching.

I hope this informations will help you to fix the bug.

Kind regards and thx again for the great work!

Overlay bug (depends on aspect ratio and manual mode)

Advertisment